Skip to content

← Public intelligence

Go package

github.com/tidwall/gjson

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5GoPublished

    Improper Validation of Array Index in GJSON

    CVE-2020-36067 · GHSA-p64j-r5f4-pwwx

    Affected
    • Go github.com/tidwall/gjson < 1.6.6
    Fixed in
    1.6.6· Vendor fix available
    Issue
    GJSON < 1.6.6 allows attackers to cause a denial of service (panic: runtime error: slice bounds out of range) via a crafted GET call.

    Recommended action: Upgrade to 1.6.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5GoPublished

    github.com/tidwall/gjson Vulnerable to REDoS attack

    CVE-2021-42836 · GHSA-ppj4-34rq-v8j9

    Affected
    • Go github.com/tidwall/gjson < 1.9.3
    Fixed in
    1.9.3· Vendor fix available
    Issue
    GJSON is a Go package that provides a fast and simple way to get values from a json document. GJSON before 1.9.3 allows a ReDoS (regular expression denial of service) attack.

    Recommended action: Upgrade to 1.9.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5GoPublished

    Denial of service in GJSON

    CVE-2020-35380 · GHSA-w942-gw6m-p62c

    Affected
    • Go github.com/tidwall/gjson < 1.6.4
    Fixed in
    1.6.4· Vendor fix available
    Issue
    GJSON before 1.6.4 allows attackers to cause a denial of service via crafted JSON. Due to improper bounds checking, maliciously crafted JSON objects can cause an out-of-bounds panic. If parsing user input, this may be used as a denial of service vector.

    Recommended action: Upgrade to 1.6.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.5GoPublished

    github.com/tidwall/gjson is vulnerable to Denial of service

    CVE-2020-36066 · GHSA-wjm3-fq3r-5x46

    Affected
    • Go github.com/tidwall/gjson < 1.6.5
    Fixed in
    1.6.5· Vendor fix available
    Issue
    GJSON <1.6.5 allows attackers to cause a denial of service (remote) via crafted JSON.

    Recommended action: Upgrade to 1.6.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →