Skip to content

← Public intelligence

Go package

github.com/stripe/stripe-cli

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Low, CVSS 2.4GoPublished

    Path traversal vulnerability in stripe-cli

    CVE-2024-45401 · GHSA-fv4g-gwpj-74gr

    Affected
    • Go github.com/stripe/stripe-cli >= 1.11.1, < 1.21.3
    Fixed in
    1.21.3· Vendor fix available
    Issue
    Impact A vulnerability exists in stripe-cli versions 1.11.1 and higher where a plugin package containing a manifest with a malformed plugin shortname installed using the --archive-url or --archive-path flags can overwrite arbitrary files. The update addresses the path traversal vulnerability by removing the ability to install plugins from an archive URL or path. There has been no evidence of exploitation of this vulnerability. Recommendation Upgrade to stripe-cli v1.21.3. Acknowledgements Thank you to 0xacb and bordiez for reporting this vulnerability. For more information Email us at security@stripe.com

    Recommended action: Upgrade to 1.21.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.7GoPublished

    Code injection in Stripe CLI on windows

    CVE-2022-24753 · GHSA-4cx6-fj7j-pjx9

    Affected
    • Go github.com/stripe/stripe-cli < 1.7.13
    Fixed in
    1.7.13· Vendor fix available
    Issue
    Impact A vulnerability in Stripe CLI exists on Windows when certain commands are run in a directory where an attacker has planted files. The commands are stripe login, stripe config -e, stripe community, and stripe open. MacOS and Linux are unaffected. An attacker who successfully exploits the vulnerability can run arbitrary code in the context of the current user. The update addresses the vulnerability by throwing an error in these situations before the code can run. There has been no evidence of exploitation of this vulnerability. Recommendation Upgrade to Stripe CLI v1.7.13. Acknowledgments Thanks to trungpabc for reporting the issue. For more information Email us at security@stripe.com.

    Recommended action: Upgrade to 1.7.13 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →