Critical, CVSS 9.1GoPublished
sing-box vulnerable to improper authentication in the SOCKS inbound
CVE-2023-43644 · GHSA-r5hm-mp3j-285g
- Affected
- Go github.com/sagernet/sing-box < 1.4.5; >= 1.5.0-beta.1, < 1.5.0-rc.5
- Fixed in
- 1.4.51.5.0-rc.5· Vendor fix available
- Issue
- Impact This vulnerability allows specially crafted requests to bypass authentication, affecting all SOCKS inbounds with user authentication. Patches Update to sing-box 1.4.5 or 1.5.0-rc.5 and later versions. Workarounds Don't expose the SOCKS5 inbound to insecure environments.
Recommended action: Upgrade to 1.5.0-rc.5 (pre-release) or 1.4.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.