Skip to content

← Public intelligence

Go package

github.com/pandatix/go-cvss

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5GoPublished

    Go-CVSS has Out-of-bounds Read vulnerability in ParseVector function

    CVE-2022-39213 · GHSA-xhmf-mmv2-4hhx

    Affected
    • Go github.com/pandatix/go-cvss >= 0.2.0, < 0.4.0
    Fixed in
    0.4.0· Vendor fix available
    Issue
    Impact When a full CVSS v2.0 vector string is parsed using ParseVector, an Out-of-Bounds Read is possible due to a lack of tests. The Go module will then panic. Patches The problem is patched in tag v0.4.0, by the commit d9d478ff0c13b8b09ace030db9262f3c2fe031f4. Workarounds The only way to avoid it is by parsing CVSS v2.0 vector strings that does not have all attributes defined (e.g. AV:N/AC:L/Au:N/C:P/I:P/A:C/E:U/RL:OF/RC:C/CDP:MH/TD:H/CR:M/IR:M/AR:M). References N/A CPE v2.3 As stated in SECURITY.md, the CPE v2.3 to refer to this Go module is cpe:2.3:a:pandatix:gocvss::::::::. The entry has already been requested to the NVD CPE dictionnary. Exploit example When ran, the following trace is returned. For more information If you have any questions or comments about this advisory: Open an issue in pandatix/go-cvss Email me at lucastesson@protonmail.com

    Recommended action: Upgrade to 0.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →