High, CVSS 8.6GoPublished
GoBGP panics due to a zero value for softwareVersionLen
CVE-2025-43971 · GHSA-7m35-vw2c-696v
- Affected
- Go github.com/osrg/gobgp/v3 >= 3.11.0, < 3.35.0
- Fixed in
- 3.35.0· Vendor fix available
- Issue
- An issue was discovered in GoBGP before 3.35.0 (introduced in v3.11.0). pkg/packet/bgp/bgp.go allows attackers to cause a panic via a zero value for softwareVersionLen.
Recommended action: Upgrade to 3.35.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.