Critical, CVSS 9.3GoPublished
OpenFlagr contains an authentication bypass vulnerability in the HTTP middleware
CVE-2026-0650 · GHSA-rwp9-5g7q-73q3
- Affected
- Go github.com/openflagr/flagr < 0.0.0-20251009103504-fe83dc87aa40
- Fixed in
- 0.0.0-20251009103504-fe83dc87aa40· Vendor fix available
- Issue
- OpenFlagr versions prior to and including 1.1.18 contain an authentication bypass vulnerability in the HTTP middleware. Due to improper handling of path normalization in the whitelist logic, crafted requests can bypass authentication and access protected API endpoints without valid credentials. Unauthorized access may allow modification of feature flags and export of sensitive data.
Recommended action: Upgrade to 0.0.0-20251009103504-fe83dc87aa40 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.