Skip to content

← Public intelligence

Go package

github.com/octo-sts/app

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.6GoPublished

    Octo STS Unauthenticated SSRF by abusing fields in OpenID Connect tokens

    CVE-2025-52477 · GHSA-h3qp-hwvr-9xcq

    Affected
    • Go github.com/octo-sts/app <= 0.5.2
    Fixed in
    0.5.3· Vendor fix available
    Issue
    Octo-STS versions before v0.5.3 are vulnerable to unauthenticated SSRF by abusing fields in OpenID Connect tokens. Malicious tokens were shown to trigger internal network requests which could reflect error logs with sensitive information. Please upgrade to v0.5.3 to resolve this issue. This version includes patch sets to sanitize input and redact logging. Many thanks to @vicevirus for reporting this issue and for assisting with remediation review. References - https://github.com/octo-sts/app/security/advisories/GHSA-h3qp-hwvr-9xcq - https://github.com/octo-sts/app/commit/b3976e39bd8c8c217c0670747d34a4499043da92 - https://github.com/octo-sts/app/commit/0f177fde54f9318e33f0bba6abaea9463a7c3afd

    Recommended action: Upgrade to 0.5.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Low, CVSS 3.7GoPublished

    octo-sts vulnerable to unauthenticated attacker causing unbounded CPU and memory usage

    CVE-2024-34079 · GHSA-75r6-6jg8-pfcq

    Affected
    • Go github.com/octo-sts/app < 0.1.0
    Fixed in
    0.1.0· Vendor fix available
    Issue
    Impact This vulnerability can spike the resource utilization of the STS service, and combined with a significant traffic volume could potentially lead to a denial of service. Patches This vulnerability existed in the repository at HEAD, we will cut a 0.1.0 release with the fix. Workarounds None References None

    Recommended action: Upgrade to 0.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →