Skip to content

← Public intelligence

Go package

github.com/mudler/LocalAI

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.2GoAmendedPublished

    LocalAI POST /models/apply permits unauthenticated server-side request forgery through gallery URLs

    CVE-2026-59707 · GHSA-8c5q-hx4g-qq23

    Affected
    • Go github.com/mudler/LocalAI < 1.40.1-0.20260703213242-2cbb3c96b34d
    Fixed in
    1.40.1-0.20260703213242-2cbb3c96b34d· Vendor fix available
    Issue
    LocalAI contains an unauthenticated server-side request forgery vulnerability in the POST /models/apply endpoint that allows attackers to fetch arbitrary internal URLs. The endpoint passes unsanitized gallery URL fields directly to gallery.GetGalleryConfigFromURLWithContext without proper validation, enabling attackers to force the server to issue HTTP GET requests to private and loopback ranges with partial response content leaked through error messages.

    Recommended action: Upgrade to 1.40.1-0.20260703213242-2cbb3c96b34d (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.4GoPublished

    LocalAI Cross-Site Scripting (XSS) vulnerability in its search functionality

    CVE-2024-9900 · GHSA-w6hh-w36c-vxmw

    Affected
    • Go github.com/mudler/LocalAI < 2.22.0
    Fixed in
    2.22.0· Vendor fix available
    Issue
    mudler/localai version v2.21.1 contains a Cross-Site Scripting (XSS) vulnerability in its search functionality. The vulnerability arises due to improper sanitization of user input, allowing the injection and execution of arbitrary JavaScript code. This can lead to the execution of malicious scripts in the context of the victim's browser, potentially compromising user sessions, stealing session cookies, redirecting users to malicious websites, or manipulating the DOM.

    Recommended action: Upgrade to 2.22.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →