Medium, CVSS 6.5GoPublished
Linkerd resource exhaustion vulnerability
CVE-2025-43915 · GHSA-42mr-jpwh-m9rv
- Affected
- Go github.com/linkerd/linkerd2 < 0.0.0-20250212165942-faa3f617eef5
- Fixed in
- 0.0.0-20250212165942-faa3f617eef5· Vendor fix available
- Issue
- In Linkerd edge releases before edge-25.2.1, and Buoyant Enterprise for Linkerd releases 2.13.0–2.13.7, 2.14.0–2.14.10, 2.15.0–2.15.7, 2.16.0–2.16.4, and 2.17.0–2.17.1, resource exhaustion can occur for Linkerd proxy metrics.
Recommended action: Upgrade to 0.0.0-20250212165942-faa3f617eef5 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.