Skip to content

← Public intelligence

Go package

github.com/kubernetes-csi/csi-proxy

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8GoPublished

    Kubernetes csi-proxy vulnerable to privilege escalation due to improper input validation

    CVE-2023-3893 · GHSA-r6cc-7wj7-gfx2

    Affected
    • Go github.com/kubernetes-csi/csi-proxy >= 0.1.0-rc1, <= 1.1.2; < 0.0.0-20230821192013-2523e6674ded; >= 1.1.3-0, < 1.1.3-0.20230821192013-2523e6674ded
    Fixed in
    1.1.3-0.20230821192013-2523e6674ded0.0.0-20230821192013-2523e6674ded1.1.3· Vendor fix available
    Issue
    Kubernetes is vulnerable to privilege escalation when a user that can create pods on Windows nodes running kubernetes-csi-proxy may be able to escalate to admin privileges on those nodes. Kubernetes clusters are only affected if they include Windows nodes running kubernetes-csi-proxy.

    Recommended action: Upgrade to 1.1.3-0.20230821192013-2523e6674ded (pre-release), 1.1.3 or 0.0.0-20230821192013-2523e6674ded (pre-release) by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →