Medium, CVSS 4.1GoPublished
kro Confused Deputy vulnerability
CVE-2025-48710 · GHSA-7633-x85h-5mqh
- Affected
- Go github.com/kro-run/kro >= 0.1.0, < 0.2.1
- Fixed in
- 0.2.1· Vendor fix available
- Issue
- kro (Kube Resource Orchestrator) 0.1.0 before 0.2.1 allows users (with permission to create or modify ResourceGraphDefinition resources) to supply arbitrary container images. This can lead to a confused-deputy scenario where kro's controllers deploy and run attacker-controlled images, resulting in unauthenticated remote code execution on cluster nodes.
Recommended action: Upgrade to 0.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.