Medium, CVSS 6.4GoPublished
Jumpserver Koko vulnerable to remote code execution on the host system via MongoDB shell
CVE-2023-43651 · GHSA-4r5x-x283-wm96
- Affected
- Go github.com/jumpserver/koko >= 2.0.0, < 2.28.20; >= 3.0.0, < 3.7.1
- Fixed in
- 3.7.12.28.20· Vendor fix available
- Issue
- Impact An authenticated user can exploit a vulnerability in MongoDB sessions to execute arbitrary commands, leading to remote code execution. This vulnerability may further be leveraged to gain root privileges on the host system. Details Through the WEB CLI interface provided by koko, a user logs into the authorized mongoDB database and exploits the MongoDB session to execute arbitrary commands. Patches Safe versions: - v2.28.20 - v3.7.1 Workarounds It is recommended to upgrade the safe versions. After upgrade, you can use the same method to check whether the vulnerability is fixed. References Thanks for Oskar Zeino-Mahmalat of Sonar found and report this vulnerability
Recommended action: Upgrade to 3.7.1 or 2.28.20 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.