High, CVSS 8.2GoPublished
Hermes improperly validates a JWT
CVE-2025-1293 · GHSA-vxm9-8mfw-vc6g
- Affected
- Go github.com/hashicorp-forge/hermes < 0.5.0
- Fixed in
- 0.5.0· Vendor fix available
- Issue
- Hermes versions up to 0.4.0 improperly validated the JWT provided when using the AWS ALB authentication mode, potentially allowing for authentication bypass. This vulnerability, CVE-2025-1293, was fixed in Hermes 0.5.0.
Recommended action: Upgrade to 0.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.