High, CVSS 7.5GoPublished
Paranoidhttp Server-Side Request Forgery vulnerability
CVE-2023-24623 · GHSA-v9mp-j8g7-2q6m
- Affected
- Go github.com/hakobe/paranoidhttp < 0.3.0
- Fixed in
- 0.3.0· Vendor fix available
- Issue
- Paranoidhttp before 0.3.0 allows SSRF because [::] is equivalent to the 127.0.0.1 address, but does not match the filter for private addresses.
Recommended action: Upgrade to 0.3.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.