Skip to content

← Public intelligence

Go package

github.com/go-skynet/LocalAI

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7GoPublished

    LocalAI path traversal vulnerability

    CVE-2024-5182 · GHSA-cpcx-r2gq-x893

    Affected
    • Go github.com/go-skynet/LocalAI < 2.16.0
    Fixed in
    2.16.0· Vendor fix available
    Issue
    A path traversal vulnerability exists in mudler/localai version 2.14.0, where an attacker can exploit the model parameter during the model deletion process to delete arbitrary files. Specifically, by crafting a request with a manipulated model parameter, an attacker can traverse the directory structure and target files outside of the intended directory, leading to the deletion of sensitive data. This vulnerability is due to insufficient input validation and sanitization of the model parameter.

    Recommended action: Upgrade to 2.16.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.3GoPublished

    LocalAI Command Injection in audioToWav

    CVE-2024-2029 · GHSA-wx43-g55g-2jf4

    Affected
    • Go github.com/go-skynet/LocalAI < 2.10.0
    Fixed in
    2.10.0· Vendor fix available
    Issue
    A command injection vulnerability exists in the TranscriptEndpoint of mudler/localai, specifically within the audioToWav function used for converting audio files to WAV format for transcription. The vulnerability arises due to the lack of sanitization of user-supplied filenames before passing them to ffmpeg via a shell command, allowing an attacker to execute arbitrary commands on the host system. Successful exploitation could lead to unauthorized access, data breaches, or other detrimental impacts, depending on the privileges of the process executing the code.

    Recommended action: Upgrade to 2.10.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →