High, CVSS 8.0GoPublished
gardenctl is vulnerable to Command Injection when used with non‑POSIX shells
CVE-2025-67508 · GHSA-fw33-qpx7-rhx2
- Affected
- Go github.com/gardener/gardenctl-v2 < 0.0.0-20251107111549-0bdc484cb5fb
- Fixed in
- 0.0.0-20251107111549-0bdc484cb5fb· Vendor fix available
- Issue
- A security vulnerability was discovered in gardenctl when it is used with non‑POSIX shells such as Fish and PowerShell. Such setup could allow an attacker with administrative privileges for a Gardener project to craft malicious credential values in infrastructure Secret objects that break out of the intended string context when evaluated in Fish or PowerShell environments used by the Gardener service operators, leading to arbitrary command execution on the operator's device. Am I vulnerable? This CVE affects all Gardener operators who use gardenctl < v2.12.0 with non‑POSIX shells such as Fish and PowerShell.
Recommended action: Upgrade to 0.0.0-20251107111549-0bdc484cb5fb (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.