Skip to content

← Public intelligence

Go package

github.com/elastic/beats

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5GoPublished

    Elasticsearch Packetbeat has Excessive Allocation of Memory and CPU via Malicious IPv4 Fragments

    CVE-2025-68388 · GHSA-fj69-23m4-ccvv

    Affected
    • Go github.com/elastic/beats >= 8.6.0, < 8.19.9; >= 9.0.0, < 9.1.9; >= 9.2.0, < 9.2.3
    Fixed in
    8.19.99.1.99.2.3· Vendor fix available
    Issue
    Allocation of resources without limits or throttling (CWE-770) allows an unauthenticated remote attacker to cause excessive allocation (CAPEC-130) of memory and CPU via the integration of malicious IPv4 fragments, leading to denial-of-service in Packetbeat.

    Recommended action: Upgrade to 9.2.3, 9.1.9 or 8.19.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.8GoPublished

    Elastic Beats inserts sensitive information into log file

    CVE-2023-49922 · GHSA-hj4r-2c9c-29h3

    Affected
    • Go github.com/elastic/beats >= 8.0.0, < 8.11.3; >= 7.0.0, < 7.17.16
    Fixed in
    8.11.37.17.16· Vendor fix available
    Issue
    An issue was discovered by Elastic whereby Beats and Elastic Agent would log a raw event in its own logs at the WARN or ERROR level if ingesting that event to Elasticsearch failed with any 4xx HTTP status code except 409 or 429. Depending on the nature of the event that Beats or Elastic Agent attempted to ingest, this could lead to the insertion of sensitive or private information in the Beats or Elastic Agent logs. Elastic has released 8.11.3 and 7.17.16 that prevents this issue by limiting these types of logs to DEBUG level logging, which is disabled by default.

    Recommended action: Upgrade to 8.11.3 or 7.17.16 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5GoPublished

    Denial of Service in Packetbeat

    CVE-2017-11480 · GHSA-9q3g-m353-cp4p

    Affected
    • Go github.com/elastic/beats < 5.6.4; >= 6.0.0-alpha1, < 6.0.0
    Fixed in
    6.0.05.6.4· Vendor fix available
    Issue
    Packetbeat versions prior to 5.6.4 and 6.0.0 are affected by a denial of service flaw in the PostgreSQL protocol handler. If Packetbeat is listening for PostgreSQL traffic and a user is able to send arbitrary network traffic to the monitored port, the attacker could prevent Packetbeat from properly logging other PostgreSQL traffic.

    Recommended action: Upgrade to 6.0.0 or 5.6.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →