Skip to content

← Public intelligence

Go package

github.com/docker/compose/v2

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.9GoPublished

    Docker Compose Vulnerable to Path Traversal via OCI Artifact Layer Annotations

    CVE-2025-62725 · GHSA-gv8h-7v7w-r22q

    Affected
    • Go github.com/docker/compose/v2 >= 2.34.0, < 2.40.2
    Fixed in
    2.40.2· Vendor fix available
    Issue
    Docker Compose trusts the path information embedded in remote OCI compose artifacts. When a layer includes the annotations com.docker.compose.extends or com.docker.compose.envfile, Compose joins the attacker‑supplied value from com.docker.compose.file/com.docker.compose.envfile with its local cache directory and writes the file there. Impact This affects any platform or workflow that resolves remote OCI compose artifacts, Docker Desktop, standalone Compose binaries on Linux, CI/CD runners, cloud dev environments is affected. An attacker can escape the cache directory and overwrite arbitrary files on the machine running docker compose, even if the user only runs read‑only commands such as docker compose config or docker compose ps. Patches v2.40.2 Workarounds NA

    Recommended action: Upgrade to 2.40.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →