Skip to content

← Public intelligence

Go package

github.com/containers/podman/v2

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.9GoPublished

    Improper Input Validation in Buildah and Podman

    CVE-2024-9407 · GHSA-fhqq-8f65-5xfc

    Affected
    • Go github.com/containers/podman/v2 <= 5.2.3
    Fixed in
    5.2.4· Vendor fix available
    Issue
    A vulnerability exists in the bind-propagation option of the Dockerfile RUN --mount instruction. The system does not properly validate the input passed to this option, allowing users to pass arbitrary parameters to the mount instruction. This issue can be exploited to mount sensitive directories from the host into a container during the build process and, in some cases, modify the contents of those mounted files. Even if SELinux is used, this vulnerability can bypass its protection by allowing the source directory to be relabeled to give the container access to host files.

    Recommended action: Upgrade to 5.2.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.3GoPublished

    Information disclosure in podman

    CVE-2020-14370 · GHSA-c3wv-qmjj-45r6

    Affected
    • Go github.com/containers/podman/v2 < 2.0.5
    Fixed in
    2.0.5· Vendor fix available
    Issue
    An information disclosure vulnerability was found in containers/podman in versions before 2.0.5. When using the deprecated Varlink API or the Docker-compatible REST API, if multiple containers are created in a short duration, the environment variables from the first container will get leaked into subsequent containers. An attacker who has control over the subsequent containers could use this flaw to gain access to sensitive information stored in such variables.

    Recommended action: Upgrade to 2.0.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.9GoPublished

    Podman has Files or Directories Accessible to External Parties

    CVE-2020-1726 · GHSA-vmhj-p9hw-vgrf

    Affected
    • Go github.com/containers/podman/v2 < 2.0.6
    Fixed in
    2.0.6· Vendor fix available
    Issue
    A flaw was discovered in Podman where it incorrectly allows containers when created to overwrite existing files in volumes, even if they are mounted as read-only. When a user runs a malicious container or a container based on a malicious image with an attached volume that is used for the first time, it is possible to trigger the flaw and overwrite files in the volume. This issue was introduced in version 1.6.0.

    Recommended action: Upgrade to 2.0.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →