Low, CVSS 3.5GoPublished
sshproxy vulnerable to SSH option injection
CVE-2024-34713 · GHSA-jmqp-37m5-49wh
- Affected
- Go github.com/cea-hpc/sshproxy <= 1.6.2
- Fixed in
- 1.6.3· Vendor fix available
- Issue
- Impact Any user authorized to connect to a ssh server using sshproxy can inject options to the ssh command executed by sshproxy. All versions of sshproxy are impacted. Patches The problem is patched starting on version 1.6.3 Workarounds The only workaround is to use the forcecommand option in sshproxy.yaml, but it's rarely relevant. References
Recommended action: Upgrade to 1.6.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.