Medium, CVSS 4.8GoPublished
Terraform Provider for ArgoCD has possible exposure to GO-2026-4337 / CVE-2025-68121
GHSA-594f-3595-c47v
- Affected
- Go github.com/argoproj-labs/terraform-provider-argocd < 1.2.3-0.20260316182343-b3364f3f32e7
- Fixed in
- 1.2.3-0.20260316182343-b3364f3f32e7· Vendor fix available
- Issue
- The terraform-provider-argocd might have been vulnerable to GO-2026-4337 / CVE-2025-68121 ("Unexpected session resumption in crypto/tls"). Details See https://pkg.go.dev/vuln/GO-2026-4337 for the upstream vulnerability. Provider versions starting with v7.15.1 are using go 1.25.8 for building and are thus no longer affected.
Recommended action: Upgrade to 1.2.3-0.20260316182343-b3364f3f32e7 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.