Medium, CVSS 6.9GoPublished
Gorush uses deprecated TLS versions
CVE-2024-41270 · GHSA-p3pf-mff8-3h47
- Affected
- Go github.com/appleboy/gorush < 1.18.5
- Fixed in
- 1.18.5· Vendor fix available
- Issue
- An issue discovered in the RunHTTPServer function in Gorush v1.18.4 allows attackers to intercept and manipulate data due to use of deprecated TLS version.
Recommended action: Upgrade to 1.18.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.