High, CVSS 8.8GoPublished
SQL injection in Apache Traffic Control
CVE-2024-45387 · GHSA-vq94-9pfv-ccqr
- Affected
- Go github.com/apache/trafficcontrol/v8 >= 8.0.0, < 8.0.2
- Fixed in
- 8.0.2· Vendor fix available
- Issue
- An SQL injection vulnerability in Traffic Ops in Apache Traffic Control <= 8.0.1, = 8.0.0 allows a privileged user with role "admin", "federation", "operations", "portal", or "steering" to execute arbitrary SQL against the database by sending a specially-crafted PUT request. Users are recommended to upgrade to version Apache Traffic Control 8.0.2 if you run an affected version of Traffic Ops.
Recommended action: Upgrade to 8.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.