Skip to content

← Public intelligence

Go package

github.com/apache/servicecomb-service-center

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.9GoPublished

    Apache ServiceComb Service-Center Exposure of Sensitive Information to an Unauthorized Actor vulnerability

    CVE-2023-44312 · GHSA-r8xp-52mq-rmm8

    Affected
    • Go github.com/apache/servicecomb-service-center < 2.2.0
    Fixed in
    2.2.0· Vendor fix available
    Issue
    Exposure of Sensitive Information to an Unauthorized Actor in Apache ServiceComb Service-Center. This issue affects Apache ServiceComb Service-Center before 2.1.0 (included). Users are recommended to upgrade to version 2.2.0, which fixes the issue.

    Recommended action: Upgrade to 2.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.2GoPublished

    Apache ServiceComb Service-Center Server-Side Request Forgery vulnerability

    CVE-2023-44313 · GHSA-9xc9-xq7w-vpcr

    Affected
    • Go github.com/apache/servicecomb-service-center < 2.2.0
    Fixed in
    2.2.0· Vendor fix available
    Issue
    Server-Side Request Forgery (SSRF) vulnerability in Apache ServiceComb Service-Center. Attackers can obtain sensitive server information through specially crafted requests.This issue affects Apache ServiceComb before 2.1.0 (included). Users are recommended to upgrade to version 2.2.0, which fixes the issue.

    Recommended action: Upgrade to 2.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5GoPublished

    Path traversal in ServiceCenter

    CVE-2021-21501 · GHSA-x6jv-5vfg-gm7x

    Affected
    • Go github.com/apache/servicecomb-service-center < 2.0.0
    Fixed in
    2.0.0· Vendor fix available
    Issue
    Improper configuration will cause ServiceComb ServiceCenter Directory Traversal problem in ServcieCenter 1.x.x versions and fixed in 2.0.0.

    Recommended action: Upgrade to 2.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →