Skip to content

← Public intelligence

Go package

github.com/answerdev/answer

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

34 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4GoPublished

    Answer vulnerable to Cross-site Scripting

    CVE-2023-1245 · GHSA-6c32-3x46-m9rh

    Affected
    • Go github.com/answerdev/answer < 1.0.6
    Fixed in
    1.0.6· Vendor fix available
    Issue
    Cross-site Scripting (XSS) - Stored in GitHub repository answerdev/answer prior to 1.0.6.

    Recommended action: Upgrade to 1.0.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.4GoPublished

    Answer vulnerable to Cross-site Scripting

    CVE-2023-1244 · GHSA-h85v-cx5m-78wj

    Affected
    • Go github.com/answerdev/answer < 1.0.6
    Fixed in
    1.0.6· Vendor fix available
    Issue
    Cross-site Scripting (XSS) - Stored in GitHub repository answerdev/answer prior to 1.0.6.

    Recommended action: Upgrade to 1.0.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.4GoPublished

    Answer vulnerable to Cross-site Scripting

    CVE-2023-0934 · GHSA-6cvf-m58q-h9wf

    Affected
    • Go github.com/answerdev/answer < 1.0.5
    Fixed in
    1.0.5· Vendor fix available
    Issue
    Cross-site Scripting (XSS) - Stored in GitHub repository answerdev/answer prior to 1.0.5.

    Recommended action: Upgrade to 1.0.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Critical, CVSS 9.8GoPublished

    Answer contains Improper Access Control vulnerability

    CVE-2023-0744 · GHSA-4cwh-8w4g-jxxh

    Affected
    • Go github.com/answerdev/answer < 1.0.4
    Fixed in
    1.0.4· Vendor fix available
    Issue
    Improper Access Control in GitHub repository answerdev/answer prior to 1.0.4.

    Recommended action: Upgrade to 1.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Critical, CVSS 9.0GoPublished

    Cross-site scripting vulnerability found in answerdev/answer

    CVE-2023-0740 · GHSA-65px-4cpf-697r

    Affected
    • Go github.com/answerdev/answer < 1.0.4
    Fixed in
    1.0.4· Vendor fix available
    Issue
    Cross-site Scripting (XSS) - Stored in GitHub repository answerdev/answer prior to 1.0.4.

    Recommended action: Upgrade to 1.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Critical, CVSS 9.0GoPublished

    Answer contains Cross-site Scripting vulnerability

    CVE-2023-0742 · GHSA-rmw8-7823-wp7f

    Affected
    • Go github.com/answerdev/answer < 1.0.4
    Fixed in
    1.0.4· Vendor fix available
    Issue
    Cross-site Scripting (XSS) - Stored in GitHub repository answerdev/answer prior to 1.0.4.

    Recommended action: Upgrade to 1.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. Critical, CVSS 9.0GoPublished

    Answer has Cross-site Scripting vulnerability

    CVE-2023-0741 · GHSA-p7wj-c85f-xq9h

    Affected
    • Go github.com/answerdev/answer < 1.0.4
    Fixed in
    1.0.4· Vendor fix available
    Issue
    Cross-site Scripting (XSS) - DOM in GitHub repository answerdev/answer prior to 1.0.4.

    Recommended action: Upgrade to 1.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  8. Critical, CVSS 9.0GoPublished

    Answer subject to Cross-site Scripting vulnerability

    CVE-2023-0743 · GHSA-hjmr-xm25-36mh

    Affected
    • Go github.com/answerdev/answer < 1.0.4
    Fixed in
    1.0.4· Vendor fix available
    Issue
    Cross-site Scripting (XSS) - Generic in GitHub repository answerdev/answer prior to 1.0.4.

    Recommended action: Upgrade to 1.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  9. Medium, CVSS 6.8GoPublished

    Answer vulnerable to Race Condition

    CVE-2023-0739 · GHSA-qx34-47fc-vv79

    Affected
    • Go github.com/answerdev/answer < 1.0.4
    Fixed in
    1.0.4· Vendor fix available
    Issue
    Race Condition in Switch in GitHub repository answerdev/answer prior to 1.0.4.

    Recommended action: Upgrade to 1.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →