Medium, CVSS 6.1GoPublished
Cross-site Scripting in Alist
CVE-2022-26533 · GHSA-jpj5-hg26-6jgc
- Affected
- Go github.com/Xhofe/alist >= 2.0.10, < 2.1.1
- Fixed in
- 2.1.1· Vendor fix available
- Issue
- Alist versions 2.0.10 through 2.1.0 were discovered to contain a cross-site scripting (XSS) vulnerability via /i/:data/ipa.plist. This issue was fixed in version 2.1.1.
Recommended action: Upgrade to 2.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.