Medium, CVSS 6.6crates.ioPublished
Miniscript allows stack consumption
CVE-2024-44073 · GHSA-rv9v-r4vm-gj8x
- Affected
- crates.io miniscript >= 12.0.0, < 12.2.0; >= 11.0.0, < 11.2.0; >= 10.0.0, < 10.2.0; < 9.2.0
- Fixed in
- 12.2.011.2.09.2.010.2.0· Vendor fix available
- Issue
- The Miniscript (aka rust-miniscript) library for Rust allows stack consumption because it does not properly track tree depth.
Recommended action: Upgrade to 12.2.0, 11.2.0, 10.2.0 or 9.2.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.