High, CVSS 7.5crates.ioPublished
libsqlite3-sys via C SQLite improperly validates array index
CVE-2022-35737 · GHSA-jw36-hf63-69r9
- Affected
- crates.io libsqlite3-sys < 0.25.1
- Fixed in
- 0.25.1· Vendor fix available
- Issue
- SQLite 1.0.12 through 3.39.x before 3.39.2 sometimes allows an array-bounds overflow if billions of bytes are used in a string argument to a C API.
Recommended action: Upgrade to 0.25.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.