Critical, CVSS 9.8crates.ioPublished
Use after free in libflate
CVE-2019-15552 · GHSA-rpcm-whqc-jfw8
- Affected
- crates.io libflate >= 0.1.14, < 0.1.25
- Fixed in
- 0.1.25· Vendor fix available
- Issue
- An issue was discovered in the libflate crate before 0.1.25 for Rust. MultiDecoder::read has a use-after-free, leading to arbitrary code execution.
Recommended action: Upgrade to 0.1.25 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.