Skip to content

← Public intelligence

crates.io package

libdav1d-sys

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.9crates.ioPublished

    libdav1d-sys affected by dav1d AV1 decoder integer overflow

    GHSA-mc39-h54g-pvw6

    Affected
    • crates.io libdav1d-sys < 0.7.0
    Fixed in
    0.7.0· Vendor fix available
    Issue
    An integer overflow in dav1d AV1 decoder that can occur when decoding videos with large frame size. This can lead to memory corruption within the AV1 decoder. We recommend upgrading to version 0.7.0 of libdav1d-sys, which includes dav1d 1.4.0.

    Recommended action: Upgrade to 0.7.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →