High, CVSS 7.5crates.ioPublished
BER/CER/DER decoder panics on invalid input
CVE-2023-39914 · GHSA-6jmw-6mxw-w4jc
- Affected
- crates.io bcder < 0.7.3
- Fixed in
- 0.7.3· Vendor fix available
- Issue
- NLnet Labs’ bcder library up to and including version 0.7.2 panics while decoding certain invalid input data rather than rejecting the data with an error. This can affect both the actual decoding stage as well as accessing content of types that utilized delayed decoding.
Recommended action: Upgrade to 0.7.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.