Critical, CVSS 9.3crates.ioAmendedPublished
Potential memory corruption in arrayfire
CVE-2018-20998 · GHSA-69fv-gw6g-8ccg
- Affected
- crates.io arrayfire < 3.6.0
- Fixed in
- 3.6.0· Vendor fix available
- Issue
- The attribute repr() added to enums to be compatible with C-FFI caused memory corruption on MSVC toolchain. arrayfire crates <= version 3.5.0 do not have this issue when used with Rust versions 1.27 or earlier. The issue only started to appear since Rust version 1.28. The issue seems to be interlinked with which version of Rust is being used. The issue was fixed in crate 3.6.0.
Recommended action: Upgrade to 3.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.