Skip to content

← Public intelligence

npm package

zx

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.6npmAmendedPublished

    zx Uses Incorrectly-Resolved Name or Reference

    CVE-2025-13437 · GHSA-w87r-vg9q-crqm

    Affected
    • npm zx < 8.8.5
    Fixed in
    8.8.5· Vendor fix available
    Issue
    When zx is invoked with --prefer-local=<path, the CLI creates a symlink named ./nodemodules pointing to <path/nodemodules. Due to a logic error in src/cli.ts (linkNodeModules / cleanup), the function returns the target path instead of the alias (symlink path). The later cleanup routine removes what it received, which deletes the target directory itself. Result: zx can delete an external <path/nodemodules outside the current working directory.

    Recommended action: Upgrade to 8.8.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.2npmAmendedPublished

    ZX Allows Environment Variable Injection for dotenv API

    CVE-2025-24959 · GHSA-qwp8-x4ff-5h87

    Affected
    • npm zx >= 8.3.1, <= 8.3.1
    Fixed in
    8.3.2· Vendor fix available
    Issue
    Impact This vulnerability is an Environment Variable Injection issue in dotenv.stringify, affecting google/zx version 8.3.1. An attacker with control over environment variable values can inject unintended environment variables into process.env. This can lead to arbitrary command execution or unexpected behavior in applications that rely on environment variables for security-sensitive operations. Applications that process untrusted input and pass it through dotenv.stringify are particularly vulnerable. Patches This issue has been patched in version 8.3.2. Users should immediately upgrade to this version to mitigate the vulnerability. Workarounds If upgrading is not feasible, users can mitigate the vulnerability by sanitizing user-controlled environment variable values before passing them to dotenv.stringify. Specifically, avoid using ", ', and backticks in values, or enforce strict validation of environment variables before usage. References - Issue Report - Security Policy - Google…

    Recommended action: Upgrade to 8.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →