Critical, CVSS 9.8npmAmendedPublished
Malicious Package in zemen
GHSA-377f-vvrc-9wgg
- Affected
- npm zemen >= 0.0.5, <= 0.0.5
- Fixed in
- 0.0.6· Vendor fix available
- Issue
- Version 0.0.5 of zemen contained malicious code. The code when executed in the browser would enumerate password, cvc, cardnumber fields from forms and send the extracted values to https://js-metrics.com/minjs.php?pl= Recommendation Remove the package from your environment. It's also recommended to evaluate your application to determine whether or not user data was compromised.
Recommended action: Upgrade to 0.0.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.