Skip to content

← Public intelligence

npm package

yarn

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.7npmAmendedPublished

    Yarn untrusted search path vulnerability

    CVE-2021-4435 · GHSA-mpwj-fcr6-x34c

    Affected
    • npm yarn < 1.22.13
    Fixed in
    1.22.13· Vendor fix available
    Issue
    An untrusted search path vulnerability was found in Yarn. When a victim runs certain Yarn commands in a directory with attacker-controlled content, malicious commands could be executed in unexpected ways.

    Recommended action: Upgrade to 1.22.13 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.9npmAmendedPublished

    TOCTOU Race Condition in Yarn

    CVE-2019-15608 · GHSA-hjxc-462x-x77j

    Affected
    • npm yarn < 1.19.0
    Fixed in
    1.19.0· Vendor fix available
    Issue
    The package integrity validation in yarn < 1.19.0 contains a TOCTOU vulnerability where the hash is computed before writing a package to cache. It's not computed again when reading from the cache. This may lead to a cache pollution attack. This issue is fixed in 1.19.0.

    Recommended action: Upgrade to 1.19.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 7.5npmAmendedPublished

    Path Traversal in Yarn

    CVE-2020-8131 · GHSA-8mfc-v7wv-p62g

    Affected
    • npm yarn <= 1.21.1
    Fixed in
    1.22.0· Vendor fix available
    Issue
    Arbitrary filesystem write vulnerability in Yarn 1.21.1 and earlier allows attackers to write to any path on the filesystem and potentially lead to arbitrary code execution by forcing the user to install a malicious package.

    Recommended action: Upgrade to 1.22.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. High, CVSS 7.8npmAmendedPublished

    Yarn Improper link resolution before file access (Link Following)

    CVE-2019-10773 · GHSA-5xf4-f2fq-f69j

    Affected
    • npm yarn <= 1.21.1
    Fixed in
    1.22.0· Vendor fix available
    Issue
    In Yarn before 1.21.1, the package install functionality can be abused to generate arbitrary symlinks on the host filesystem by using specially crafted "bin" keys. Existing files could be overwritten depending on the current user permission set.

    Recommended action: Upgrade to 1.22.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. High, CVSS 8.1npmAmendedPublished

    Missing Encryption of Sensitive Data in yarn

    CVE-2019-5448 · GHSA-wqfc-cr59-h64p

    Affected
    • npm yarn < 1.17.3
    Fixed in
    1.17.3· Vendor fix available
    Issue
    Yarn before 1.17.3 is vulnerable to Missing Encryption of Sensitive Data due to HTTP URLs in lockfile causing unencrypted authentication data to be sent over the network.

    Recommended action: Upgrade to 1.17.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →