High, CVSS 8.8npmAmendedPublished
xterm vulnerable to remote code execution
CVE-2019-0542 · GHSA-mc23-976p-j42x
- Affected
- npm xterm < 3.8.1; >= 3.9.0, < 3.9.2; >= 3.10.0, < 3.10.1
- Fixed in
- 3.8.13.9.23.10.1· Vendor fix available
- Issue
- A remote code execution vulnerability exists in Xterm.js when the component mishandles special characters.
Recommended action: Upgrade to 3.10.1, 3.9.2 or 3.8.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.