High, CVSS 8.8npmAmendedPublished
Improper Input Validation (RCE)
CVE-2021-26814 · GHSA-w36g-q975-37rg
- Affected
- npm wazuh >= 4.0.0, <= 4.0.3
- Fixed in
- 4.0.4· Vendor fix available
- Issue
- Wazuh API in Wazuh from 4.0.0 to 4.0.3 allows authenticated users to execute arbitrary code with administrative privileges via /manager/files URI. An authenticated user to the service may exploit incomplete input validation on the /manager/files API to inject arbitrary code within the API service script.
Recommended action: Upgrade to 4.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.