Critical, CVSS 9.8npmAmendedPublished
Malicious Package in vue-backbone
GHSA-5635-9mvj-r6hp
- Affected
- npm vue-backbone >= 0.1.2, <= 0.1.2
- Fixed in
- 0.1.3· Vendor fix available
- Issue
- Version 0.1.2 of vue-backbone contained malicious code. The code when executed in the browser would enumerate password, cvc and cardnumber fields from forms and send the extracted values to https://js-metrics.com/minjs.php?pl= Recommendation Remove the package from your environment and evaluate your application to determine whether or not user data was compromised.
Recommended action: Upgrade to 0.1.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.