Skip to content

← Public intelligence

npm package

vditor

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1npmAmendedPublished

    Vditor Cross-site Scripting vulnerability

    CVE-2021-32855 · GHSA-vfmp-9999-6wqj

    Affected
    • npm vditor < 3.8.7
    Fixed in
    3.8.7· Vendor fix available
    Issue
    Vditor is a browser-side Markdown editor. Versions prior to 3.8.7 are vulnerable to copy-paste cross-site scripting (XSS). For this particular type of XSS, the victim needs to be fooled into copying a malicious payload into the text editor. Version 3.8.7 contains a patch for this issue.

    Recommended action: Upgrade to 3.8.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.4npmAmendedPublished

    Cross-site Scripting in vditor

    CVE-2022-0350 · GHSA-689x-x68p-fph3

    Affected
    • npm vditor < 3.8.13
    Fixed in
    3.8.13· Vendor fix available
    Issue
    Cross-site Scripting (XSS) - Stored in GitHub repository vanessa219/vditor prior to 3.8.13.

    Recommended action: Upgrade to 3.8.13 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 5.4npmAmendedPublished

    Cross-site Scripting in vditor

    CVE-2022-0341 · GHSA-pq37-4c4g-v38c

    Affected
    • npm vditor < 3.8.11
    Fixed in
    3.8.11· Vendor fix available
    Issue
    vditor prior to version 3.8.11 is vulnerable to cross-site scripting.

    Recommended action: Upgrade to 3.8.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Medium, CVSS 5.4npmAmendedPublished

    vditor Vulnerable to Cross-site Scripting in SVG events

    CVE-2021-4103 · GHSA-cxm3-v4mv-6mh8

    Affected
    • npm vditor < 3.8.11
    Fixed in
    3.8.11· Vendor fix available
    Issue
    vditor does not filter user input in SVG events, leading to XSS PoC

    Recommended action: Upgrade to 3.8.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →