Skip to content

← Public intelligence

npm package

valine

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.6npmAmendedPublished

    Valine code injection vulnerability

    CVE-2022-38545 · GHSA-mcvg-g9wx-v5vx

    Affected
    • npm valine < 1.5.0
    Fixed in
    1.5.0· Vendor fix available
    Issue
    Valine was discovered to contain a remote code execution (RCE) vulnerability which allows attackers to execute arbitrary code via a crafted POST request.

    Recommended action: Upgrade to 1.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.4npmAmendedPublished

    Cross site scripting in valine

    CVE-2020-28847 · GHSA-6xvq-2gj8-4276

    Affected
    • npm valine < 1.4.15
    Fixed in
    1.4.15· Vendor fix available
    Issue
    valine is a fast, simple & powerful comment system. Cross Site Scripting (XSS) vulnerability in xCss Valine v1.4.14 via the nick parameter to /classes/Comment. A fix was released in version 1.4.15.

    Recommended action: Upgrade to 1.4.15 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 6.1npmAmendedPublished

    Valine HTML Injection

    CVE-2018-19289 · GHSA-hhrp-qm88-xjr3

    Affected
    • npm valine <= 1.3.3
    Fixed in
    1.3.4· Vendor fix available
    Issue
    An issue was discovered in Valine v1.3.3. It allows HTML injection, which can be exploited for JavaScript execution via an EMBED element in conjunction with a .pdf file.

    Recommended action: Upgrade to 1.3.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →