Skip to content

← Public intelligence

npm package

ungit

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8npmAmendedPublished

    Command Injection in ungit

    CVE-2022-25766 · GHSA-hf8c-xr89-vfm5

    Affected
    • npm ungit < 1.5.20
    Fixed in
    1.5.20· Vendor fix available
    Issue
    The package ungit before 1.5.20 are vulnerable to Remote Code Execution (RCE) via argument injection. The issue occurs when calling the /api/fetch endpoint. User controlled values (remote and ref) are passed to the git fetch command. By injecting some git options it was possible to get arbitrary command execution.

    Recommended action: Upgrade to 1.5.20 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. UnratednpmAmendedPublished

    Command Injection in ungit

    CVE-2015-4130 · GHSA-vjfr-p6hp-jqqw

    Affected
    • npm ungit <= 0.8.4
    Fixed in
    0.9.0· Vendor fix available
    Issue
    Versions of ungit prior to 0.9.0 are affected by a command injection vulnerability in the url parameter. Recommendation Update version 0.9.0 or later.

    Recommended action: Upgrade to 0.9.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →