Skip to content

← Public intelligence

npm package

underscore

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.2npmAmendedPublished

    Underscore has unlimited recursion in _.flatten and _.isEqual, potential for DoS attack

    CVE-2026-27601 · GHSA-qpx9-hpmf-5gmw

    Affected
    • npm underscore <= 1.13.7
    Fixed in
    1.13.8· Vendor fix available
    Issue
    Impact In simple words, some programs that use .flatten or .isEqual could be made to crash. Someone who wants to do harm may be able to do this on purpose. This can only be done if the program has special properties. It only works in Underscore versions up to 1.13.7. A more detailed explanation follows. In affected versions of Underscore, the .flatten and .isEqual functions use recursion without a depth limit. Under very specific conditions, detailed below, an attacker could exploit this in a Denial of Service (DoS) attack by triggering a stack overflow. A proof of concept (PoC) for this type of attack with .isEqual: A proof of concept (PoC) for this type of attack with .flatten: An application that crashes because of this can be restarted, so the bug is most relevant to applications for which continued operation is important, such as server applications. Furthermore, an application is only vulnerable to this type of attack if ALL of the following conditions are met: - Untrusted…

    Recommended action: Upgrade to 1.13.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.8npmAmendedPublished

    Arbitrary Code Execution in underscore

    CVE-2021-23358 · GHSA-cf4h-3jhx-xvhq

    Affected
    • npm underscore >= 1.3.2, < 1.12.1
    Fixed in
    1.12.1· Vendor fix available
    Issue
    The package underscore from 1.13.0-0 and before 1.13.0-2, from 1.3.2 and before 1.12.1 are vulnerable to Arbitrary Code Execution via the template function, particularly when a variable property is passed as an argument as it is not sanitized.

    Recommended action: Upgrade to 1.12.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →