Skip to content

← Public intelligence

npm package

uglify-js

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5npmAmendedPublished

    Regular Expression Denial of Service in uglify-js

    CVE-2015-8858 · GHSA-c9f4-xj24-8jqx

    Affected
    • npm uglify-js < 2.6.0
    Fixed in
    2.6.0· Vendor fix available
    Issue
    Versions of uglify-js prior to 2.6.0 are affected by a regular expression denial of service vulnerability when malicious inputs are passed into the parse() method. Proof of Concept Results Recommendation Update to version 2.6.0 or later.

    Recommended action: Upgrade to 2.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.8npmAmendedPublished

    Incorrect Handling of Non-Boolean Comparisons During Minification in uglify-js

    CVE-2015-8857 · GHSA-34r7-q49f-h37c

    Affected
    • npm uglify-js < 2.4.24
    Fixed in
    2.4.24· Vendor fix available
    Issue
    Versions of uglify-js prior to 2.4.24 are affected by a vulnerability which may cause crafted JavaScript to have altered functionality after minification. Recommendation Upgrade UglifyJS to version = 2.4.24.

    Recommended action: Upgrade to 2.4.24 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →