High, CVSS 7.5npmAmendedPublished
Terser insecure use of regular expressions leads to ReDoS
CVE-2022-25858 · GHSA-4wf5-vphf-c2xc
- Affected
- npm terser < 4.8.1; >= 5.0.0, < 5.14.2
- Fixed in
- 5.14.24.8.1· Vendor fix available
- Issue
- The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service (ReDoS) due to insecure usage of regular expressions.
Recommended action: Upgrade to 5.14.2 or 4.8.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.