Skip to content

← Public intelligence

npm package

terriajs-server

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7npmAmendedPublished

    TerriaJS-Server has a domain validation bypass vulnerability in its proxy allowlist

    CVE-2026-27818 · GHSA-w789-49fc-v8hr

    Affected
    • npm terriajs-server < 4.0.3
    Fixed in
    4.0.3· Vendor fix available
    Issue
    Impact A validation bug allows an attacker to proxy domains not explicitly allowed in the proxyableDomains configuration. The validation only checks if a hostname ended with an allowed domain. This meant: If example.com is allowed in proxyableDomains: - ✅ example.com is allowed (correct) - ✅ api.example.com is allowed (correct) - ⚠️ maliciousexample.com is allowed (incorrect) An attacker could register maliciousexample.com and proxy content through terriajs-server, bypassing proxy restrictions. Patches All versions up to 4.0.2 are affected. Upgrade to 4.0.3 to address the vulnerability.

    Recommended action: Upgrade to 4.0.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. UnratednpmAmendedPublished

    Server-Side Request Forgery in terriajs-server

    GHSA-p72p-rjr2-r439

    Affected
    • npm terriajs-server < 2.7.4
    Fixed in
    2.7.4· Vendor fix available
    Issue
    Versions of terriajs-serverprior to 2.7.4 are vulnerable to Server-Side Request Forgery (SSRF). If an attacker has access to a server whitelisted by the terriajs-server proxy or if the attacker is able to modify the DNS records of a domain whitelisted by the terriajs-server proxy, the attacker can use the terriajs-server proxy to access any HTTP-accessible resources that are accessible to the server, including private resources in the hosting environment. Recommendation Upgrade to version 2.7.4 or later.

    Recommended action: Upgrade to 2.7.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →