Medium, CVSS 6.1npmAmendedPublished
Cross Site Scripting vulnerability in store2
CVE-2024-57556 · GHSA-w5hq-hm5m-4548
- Affected
- npm store2 < 2.14.4
- Fixed in
- 2.14.4· Vendor fix available
- Issue
- Cross Site Scripting vulnerability in nbubna store v.2.14.2 and before allows a remote attacker to execute arbitrary code via the store.deep.js component
Recommended action: Upgrade to 2.14.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.