High, CVSS 7.5npmAmendedPublished
Regular Expression Denial of Service in sshpk
CVE-2018-3737 · GHSA-2m39-62fm-q8r3
- Affected
- npm sshpk < 1.13.2
- Fixed in
- 1.13.2· Vendor fix available
- Issue
- Versions of sshpk before 1.13.2 or 1.14.1 are vulnerable to regular expression denial of service when parsing crafted invalid public keys. Recommendation Update to version 1.13.2, 1.14.1 or later.
Recommended action: Upgrade to 1.13.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.