Skip to content

← Public intelligence

npm package

squirrelly

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.9npmAmendedPublished

    squirrelly Code Injection vulnerability

    CVE-2024-40453 · GHSA-w5pw-gmcw-rfc8

    Affected
    • npm squirrelly >= 9.0.0, < 9.1.0
    Fixed in
    9.1.0· Vendor fix available
    Issue
    squirrellyjs squirrelly v9.0.0 was discovered to contain a code injection vulnerability via the component options.varName. The issue was fixed in version 9.1.0.

    Recommended action: Upgrade to 9.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.0npmAmendedPublished

    Insecure template handling in Squirrelly

    CVE-2021-32819 · GHSA-q8j6-pwqx-pm96

    Affected
    • npm squirrelly <= 8.0.8
    Fixed in
    9.0.0· Vendor fix available
    Issue
    Squirrelly is a template engine implemented in JavaScript that works out of the box with ExpressJS. Squirrelly mixes pure template data with engine configuration options through the Express render API. By overwriting internal configuration options remote code execution may be triggered in downstream applications. Version 9.0.0 has a fix for this issue. For complete details refer to the referenced GHSL-2021-023.

    Recommended action: Upgrade to 9.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →