High, CVSS 7.8npmAmendedPublished
Snyk CLI affected by Command Injection vulnerability
CVE-2022-40764 · GHSA-hpqj-7cj6-hfj8
- Affected
- npm snyk-go-plugin < 1.19.1
- Fixed in
- 1.19.1· Vendor fix available
- Issue
- Snyk CLI before 1.996.0 allows arbitrary command execution, affecting Snyk IDE plugins and the snyk npm package. Exploitation could follow from the common practice of viewing untrusted files in the Visual Studio Code editor, for example. The original demonstration was with shell metacharacters in the vendor.json ignore field, affecting snyk-go-plugin before 1.19.1. This affects, for example, the Snyk TeamCity plugin (which does not update automatically) before 20220930.142957.
Recommended action: Upgrade to 1.19.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.