Medium, CVSS 5.4npmAmendedPublished
Smoothie vulnerable to Cross-site Scripting when tooltipLabel or strokeStyle are controlled by users
CVE-2022-25929 · GHSA-g662-qq45-ppwm
- Affected
- npm smoothie >= 1.31.0, < 1.36.1
- Fixed in
- 1.36.1· Vendor fix available
- Issue
- The package smoothie from 1.31.0 and before 1.36.1 are vulnerable to Cross-site Scripting (XSS) due to improper user input sanitization in strokeStyle and tooltipLabel properties. Exploiting this vulnerability is possible when the user can control these properties.
Recommended action: Upgrade to 1.36.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.